Page 1 of 1

Has The Forum Died? Been Anywhere on your Kato?

Posted: Mon Nov 05, 2018 9:26 pm
by Aussie Dave
Just wondering....... seems like nobody rides much....... or are out riding and haven't stopped to post any pics :lol:.

Always interesting to see our Kato's out in the wild...... show em, don't hide em :mrgreen:

...... :lol: ......anybody still out there?......... :lol:........

Re: Has The Forum Died? Been Anywhere on your Kato?

Posted: Tue Nov 06, 2018 7:24 pm
by Magic Wand
No
Have no pictures from this year
No

:lol:

/M
-

Re: Has The Forum Died? Been Anywhere on your Kato?

Posted: Tue Nov 06, 2018 9:02 pm
by Aussie Dave
:lol: Same for me.... been a long year..... read a post on another site that said our forum "still had a pulse" but it's been very quiet last few weeks........ :P

Anyway, good to know there is at least one other reader on the planet ;)

Re: Has The Forum Died? Been Anywhere on your Kato?

Posted: Sun Nov 11, 2018 9:28 am
by mrslackloin
I figure you're *so* desperate for any bike action, Dave, that I can post this shitty, shitty video from my first attempt at using the Contour on the GT.

https://youtu.be/0p4So8H0dBM

I know, I know. Stardom awaits.


Re: Has The Forum Died? Been Anywhere on your Kato?

Posted: Mon Nov 12, 2018 4:36 am
by Aussie Dave
:lol: .. 8-) ..... Ahhh, Canungra,...... the Outpost Cafe,......... hoping to be back to a regular soon...... :mrgreen: .

thanks Mark...... errr, the GT's tank is wiiide eh :lol:

Hey...... you parked in my spot...... :lol: :lol: :lol: .... SDGT front and centre...... 8-)