Anyone else ever forget they had panniers on and go 150mph +?

Post Reply
That_Al_Guy
125cc
125cc
Posts: 7
Joined: Thu Aug 17, 2017 4:50 pm
Country: US
City: Berkeley
Year: 2017

Anyone else ever forget they had panniers on and go 150mph +?

Post by That_Al_Guy » Tue Apr 03, 2018 1:14 am

When you get to your destination the side panels are gone.

You think I could claim factory defect and get them for free?ImageImage

Sent from my SAMSUNG-SM-G935A using Tapatalk


jjscsix
675cc
675cc
Posts: 226
Joined: Mon Jan 01, 2018 4:41 pm
Country: USA
City: Houston
Year: 2017
Colour: Silver

Re: Anyone else ever forget they had panniers on and go 150mph +?

Post by jjscsix » Tue Apr 03, 2018 2:51 am

Wow, never saw that coming. Good thing I ride without them. But I will one day and need to remember.
2017 KTM Superduke GT, 2017 Yamaha FJR1300, 2012 Ducati 1199 Panigale

dasjefe
125cc
125cc
Posts: 25
Joined: Mon Apr 02, 2018 12:47 am
Country: United States
City: TAYLOR
Year: 2017

Re: Anyone else ever forget they had panniers on and go 150mph +?

Post by dasjefe » Tue Apr 03, 2018 3:04 am

Wow. I've been up to about 130 with them on and did not shed any parts. I don't know if they will replace them or not. One of my pannier's little plastic retaining cable thingie broke and I asked for a few one... it has been a couple of weeks and the dealership is still waiting for a response from KTM. According to my dealer, they don't typically sell any of the individual components for the panniers and there are no part numbers for them in the fiche. The panniers are made by Shad for KTM. You might be able to get something out of them?

MarkLH69
125cc
125cc
Posts: 26
Joined: Sat Sep 30, 2017 2:30 pm
Country: Australia
City: Perth
Year: 2017

Re: Anyone else ever forget they had panniers on and go 150mph +?

Post by MarkLH69 » Tue Apr 03, 2018 3:41 am

Well I guess that's a lot better than the whole things detaching .. not great though.


Sent from my Pixel 2 using Tapatalk


That_Al_Guy
125cc
125cc
Posts: 7
Joined: Thu Aug 17, 2017 4:50 pm
Country: US
City: Berkeley
Year: 2017

Re: Anyone else ever forget they had panniers on and go 150mph +?

Post by That_Al_Guy » Tue Apr 03, 2018 3:59 am

That_Al_Guy wrote:When you get to your destination the side panels are gone.

You think I could claim factory defect and get them for free?ImageImage

Sent from my SAMSUNG-SM-G935A using Tapatalk
I wonder if they exploded off simultaneously? Would have looked kinda cool at least.

Sent from my SAMSUNG-SM-G935A using Tapatalk


Dewayne Edwards 1974
250cc
250cc
Posts: 56
Joined: Fri Jun 23, 2017 5:16 pm
Country: united states
City: Slocomb
Year: 2016

Re: Anyone else ever forget they had panniers on and go 150mph +?

Post by Dewayne Edwards 1974 » Tue Apr 03, 2018 11:52 pm

That sucks, I’ve been up to 120-130 with them on with no problems. I will def be more cautious.


Sent from my iPhone using Tapatalk

eXiLe88
125cc
125cc
Posts: 11
Joined: Mon Oct 09, 2017 9:10 pm
Country: Italy
City: Milan
Year: 2017
Colour: Black

Re: Anyone else ever forget they had panniers on and go 150mph +?

Post by eXiLe88 » Tue Apr 10, 2018 10:26 pm

I went 155mph (260kph) with panniers and back box.

I checked after and it was all rock solid

Still kinda cool to image they just flew away, but hey...I had friend of mine whose back box opened at 140kph.
Nothing came out but it was funny trying to explain what happened when I stopped him

MarkLH69
125cc
125cc
Posts: 26
Joined: Sat Sep 30, 2017 2:30 pm
Country: Australia
City: Perth
Year: 2017

Re: Anyone else ever forget they had panniers on and go 150mph +?

Post by MarkLH69 » Thu Apr 19, 2018 1:38 pm

Looks like the new model panniers might do the same ..Image

Sent from my SM-T800 using Tapatalk


That_Al_Guy
125cc
125cc
Posts: 7
Joined: Thu Aug 17, 2017 4:50 pm
Country: US
City: Berkeley
Year: 2017

Re: Anyone else ever forget they had panniers on and go 150mph +?

Post by That_Al_Guy » Thu Apr 19, 2018 8:03 pm

MarkLH69 wrote:Looks like the new model panniers might do the same ..Image

Sent from my SM-T800 using Tapatalk
That's hilarious. Good looking out!

Sent from my SAMSUNG-SM-G935A using Tapatalk


User avatar
Aussie Dave
990cc
990cc
Posts: 973
Joined: Sat Mar 04, 2017 7:30 am
Country: Australia
City: Brisbane
Year: 2017

Re: Anyone else ever forget they had panniers on and go 150mph +?

Post by Aussie Dave » Thu Jul 12, 2018 6:28 am

Nah..... these test mules are disguised to try to fool bike mag spotters, so the covers have been intentionally removed or are just old cases lying around which have been used to hold data logging equipment - the 2019 model uses the same cases as the 16-18 models.

I thought I had read that the 2016 sidecases were prone to 'de-cover' at speed, but that the later cases had the covers screwed on so they wouldn't go their own way at speed..... but on the upside - the cases look good in all black... ;) ....... maybe the 'naked' look will catch on?

:lol:
Last edited by Aussie Dave on Thu Jun 27, 2019 11:22 pm, edited 2 times in total.
2017 1290GT 27,484km, 05 CBR1100XX 130k kms

Prev loves...Capo1200TP-014, CBR11xx-002, 2xFZR1000genisis-94, FJ1200-89, FJ1100-84, XS1100P, VF1000F-83, CX500, VF750S, KZ1000J1-81, KZ1000ST-79, CB750F2-77, CB360T-74, CB175.. started it all in 1974 ;)

User avatar
Steve-Gnome
125cc
125cc
Posts: 16
Joined: Mon Mar 11, 2019 8:56 am
Country: Australia
City: Adelaide
Year: 2019

Re: Anyone else ever forget they had panniers on and go 150mph +?

Post by Steve-Gnome » Sun Mar 17, 2019 3:48 am

Haven't done that speed on mine yet - still running in! But I did take the coloured panels off mine as I wrapped then in clear protector wrap as I keep sliding my boots over them when I get on and end up with black strips all over the coloured part. The '19 GT versions have three screws on the inside top edge holding them in place. They were a bitch to get off. But with the screws in the gap between the lid and body, I dont see them coming out even if they came loose.

Dorman
50cc
50cc
Posts: 1
Joined: Wed Jun 19, 2019 6:07 am
Country: USA
City: Ferndale
Year: 2019
Colour: Black & Orange

Re: Anyone else ever forget they had panniers on and go 150mph +?

Post by Dorman » Wed Jun 19, 2019 6:15 am

My 2019 SDGT bags lost that piece after only a week of ownership. Maybe 300 miles on it. I was only going about 80 mph or so when i think it happened. I took it back to the dealership and I am also waiting on KTM to find out what they are going to do. The service manager said he thought they would probably just replace both saddle bags. Also unrelated, has anyone else had a general failure alarm when they first start the bike. This alarm came in when i was leaving work and had me concerned because it was a big red message on the screen. I shut it down, waited a few minutes and started it back up and it was still there. I hit the enter button and it cleared and it hasnt happened again. Not sure if it was some sort of low voltage error or what.

User avatar
Aussie Dave
990cc
990cc
Posts: 973
Joined: Sat Mar 04, 2017 7:30 am
Country: Australia
City: Brisbane
Year: 2017

Re: Anyone else ever forget they had panniers on and go 150mph +?

Post by Aussie Dave » Thu Jun 27, 2019 11:05 pm

Dorman wrote:
Wed Jun 19, 2019 6:15 am
My 2019 SDGT bags lost that piece after only a week of ownership. Maybe 300 miles on it. I was only going about 80 mph or so when i think it happened. I took it back to the dealership and I am also waiting on KTM to find out what they are going to do. The service manager said he thought they would probably just replace both saddle bags. Also unrelated, has anyone else had a general failure alarm when they first start the bike. This alarm came in when i was leaving work and had me concerned because it was a big red message on the screen. I shut it down, waited a few minutes and started it back up and it was still there. I hit the enter button and it cleared and it hasnt happened again. Not sure if it was some sort of low voltage error or what.

G'day Dorman...... I've seen a couple of weirdo warning messages from time to time...... never anything actually wrong....... one was a suspension failure warning and a 'check engine warning symbol' caused by a failing dongle I had installed for the charcoal canister removal (once the blown dongle was replaced by the oem purge valve, the error cleared).

Do you have any dongles on your SDGT? I have been told they can cause many problems and though I have tried the O2 fuel and ESE dongles (and the unnescessary CH canister dongle) on mine, I am currently running 'dongle free' .....with the 2019 ECU upgrade on my stock 17SDGT.

For 16-18 SDGT owners - MAKE SURE YOU ASK FOR THIS UPGRADE - it fixes rebound damping as well as improving engine maps - I suspect there's now no need for any dongles etc for a stock 16-18 bike.



There was a report I read way back in 2017 about early version 016 Shad cases made for the GT, the covers were only clipped on. I had to wait 6 weeks for a shipment to arrive in Aus when I bought my GT in 2/17 and they were reported to have been fixed on more securely (screws)....... I've not ridden with the cases at high speed..... I don't like them because they are small, awkward to pack, and feel like speedbrakes due to their scalloped passenger leg shape - but they are narrower and lighter than my 40Ltr Givi cases :lol:

Next trip away I'll have to try them again....... but I have no need to do very high speeds with cases on - we have too many camera's as well as crap/dangerous secondary roads, so we keep the speeds down-ish ;)

PS I'd have thought the covers were a replaceable item..... my BMW mates can buy new covers for their cases when they want to replace due to scratches/boot scrapes/tipover evidence......

The cases look pretty good without the coloured covers...... I might take mine off to preserve them from my boot scrapes :lol:
2017 1290GT 27,484km, 05 CBR1100XX 130k kms

Prev loves...Capo1200TP-014, CBR11xx-002, 2xFZR1000genisis-94, FJ1200-89, FJ1100-84, XS1100P, VF1000F-83, CX500, VF750S, KZ1000J1-81, KZ1000ST-79, CB750F2-77, CB360T-74, CB175.. started it all in 1974 ;)

Tangaroa
50cc
50cc
Posts: 1
Joined: Fri Aug 30, 2019 11:31 pm
Country: États-Unis
City: Port Charlotte
Year: 2019
Colour: White

Re: Anyone else ever forget they had panniers on and go 150mph +?

Post by Tangaroa » Sun Sep 22, 2019 2:32 pm

The metal KTM stickers on both panniers of my 2019 SDGT are becoming unglued. KTM could not replace those stickers, so they are changing both panniers.

User avatar
Clogan
500cc
500cc
Posts: 98
Joined: Sat Oct 21, 2017 5:50 pm
Country: United States
City: Harrison
Year: 2017
Colour: Black & Orange

Re: Anyone else ever forget they had panniers on and go 150mph +?

Post by Clogan » Tue Sep 24, 2019 12:04 am

Tangaroa wrote:
Sun Sep 22, 2019 2:32 pm
The metal KTM stickers on both panniers of my 2019 SDGT are becoming unglued. KTM could not replace those stickers, so they are changing both panniers.
I had to buy one of those buggers, $20 bucks US or so. I can get the part number if you need it.

I could use a right side case if you are in a position to sell one.

User avatar
Clogan
500cc
500cc
Posts: 98
Joined: Sat Oct 21, 2017 5:50 pm
Country: United States
City: Harrison
Year: 2017
Colour: Black & Orange

Re: Anyone else ever forget they had panniers on and go 150mph +?

Post by Clogan » Tue Sep 24, 2019 12:26 am

Tangaroa wrote:
Sun Sep 22, 2019 2:32 pm
The metal KTM stickers on both panniers of my 2019 SDGT are becoming unglued. KTM could not replace those stickers, so they are changing both panniers.
I had to buy one of those buggers, $20 bucks US or so. I can get the part number if you need it. (Edited to add)

I could use a right side case if you are in a position to sell one.
Attachments
IMG_20190923_180547612.jpg
KTM side case sticker

Post Reply