Remus link pipe

Post Reply
Flingit
125cc
125cc
Posts: 28
Joined: Sun Apr 16, 2017 10:04 am
Country: South Africa
City: Hillcrest
Year: 2017

Remus link pipe

Post by Flingit » Thu Aug 10, 2017 6:26 am

I cant wait! My Remus link pipe should arrive today! It's taken the best part of 4 months to find the correct link pipe WITH a device to fit into the exhaust servo. Holding thumbs!

DaveNZ
675cc
675cc
Posts: 274
Joined: Thu Oct 13, 2016 10:20 pm
Country: New Zealand
City: New plymouth
Year: 2016

Re: Remus link pipe

Post by DaveNZ » Thu Aug 10, 2017 6:36 am

Ive done mine, pay careful attention to where the cam that pulls the valve cables position is, so you can fit the supplied cam in the right spot, also do the 02 sensor removal kit, so your bike doesn't run to lean.good luck. :)
2016 1290GT-remus link and muffler, 2010 Black 1200 Multistrada full Termi system with mapping, 2005 SMR 640, full Titanium system, Mikuni flatside racing carb, 2 sets of wheels, 18 litre tank, and a nice soft seat.

Flingit
125cc
125cc
Posts: 28
Joined: Sun Apr 16, 2017 10:04 am
Country: South Africa
City: Hillcrest
Year: 2017

Re: Remus link pipe

Post by Flingit » Sat Aug 12, 2017 6:19 am

Fitted it last night, and yes, pay very careful attention to the servo position. It took a couple of attempts, but it seems fine now. Now the bike sounds like it looks, and I don't think a slip on is necessary. I will now get the "Akro" map fitted at the 1st service, due in 150kms as the bike feels a bit lean, but I do like the "pops" on trailing throttle! A mod definitely worth doing.

Flingit
125cc
125cc
Posts: 28
Joined: Sun Apr 16, 2017 10:04 am
Country: South Africa
City: Hillcrest
Year: 2017

Re: Remus link pipe

Post by Flingit » Sat Aug 12, 2017 2:37 pm

So I went for a short ride this morning to test and all was well; very nice in fact. I left the bike for a few hours and went on another short ride to tpwn tp collect something. Upon starting, I got the dreaded MTC failure and limp mode.... I crawled home and pulled the servo off again, but cant see anything wrong. With it off, I turned the key on and off a fee times and the servo seems confused. Not turning through its full range. Any ideas; could it just be coincidence, and its failed? I also has a strange noise from the starter motor today. Almost like a jamming sound? Are there issues with the starters?Thanks in advance. PS: mileage is only 800kms

DaveNZ
675cc
675cc
Posts: 274
Joined: Thu Oct 13, 2016 10:20 pm
Country: New Zealand
City: New plymouth
Year: 2016

Re: Remus link pipe

Post by DaveNZ » Sat Aug 12, 2017 8:53 pm

There seems to be a few problems with the starters, theres been a few guys here having problems, i think its a part replacement, so warranty issue. as for your fault code (MTC) if you have the little cam (Remus)in the right position, leav it there, mine threw a fault code, i walked away under frustration, then went back next day and all was good, and haven't had any probs since, i did the remus cam and link pipe and muffler at 600Ks, now travelled over 10,000. and no hickups. i notice the bike electronics like when ignition turned on, its needs to cycle through its dash menu, before start up, and also don't use the kill switch, while the bike is going through its initial dash set up.
2016 1290GT-remus link and muffler, 2010 Black 1200 Multistrada full Termi system with mapping, 2005 SMR 640, full Titanium system, Mikuni flatside racing carb, 2 sets of wheels, 18 litre tank, and a nice soft seat.

Dewayne Edwards 1974
125cc
125cc
Posts: 23
Joined: Fri Jun 23, 2017 5:16 pm
Country: united states
City: Slocomb
Year: 2016

Re: Remus link pipe

Post by Dewayne Edwards 1974 » Mon Aug 14, 2017 1:56 am

As for the starter sound I took mine in for same thing, it's one of 3 gears they think so I will have to drop the bike off for them to take apart and find out then KTM will send them the part. I'm waiting to do that after my trip coming up to Deals Gap. Going to need the bike for that


Sent from my iPhone using Tapatalk

Flingit
125cc
125cc
Posts: 28
Joined: Sun Apr 16, 2017 10:04 am
Country: South Africa
City: Hillcrest
Year: 2017

Re: Remus link pipe

Post by Flingit » Mon Aug 28, 2017 8:11 pm

I was told today that they'll be replacing the torque limiter of the starter. We'll have to wait and see.

Post Reply