Horn Problem?

el_nino
125cc
125cc
Posts: 7
Joined: Tue Sep 13, 2016 5:28 pm
Country: United States
City: Queens
Year: 2016
Colour: Black & Orange

Re: Horn Problem?

Post by el_nino » Fri Oct 21, 2016 8:23 pm

Same problem here on a 2016 SDR.

Plake
125cc
125cc
Posts: 12
Joined: Sun Oct 16, 2016 1:48 pm
Country: UK
City: Brighton
Year: 2016
Colour: Black

Re: Horn Problem?

Post by Plake » Sat Oct 22, 2016 1:03 pm

MR C wrote:Where will you fit the Denali ! theres very little room .
I reckon it'll sit OK on the left side behind the radiator. It's in the eye of the beholder obvs but I quite like the look of them.

DaveNZ
675cc
675cc
Posts: 285
Joined: Thu Oct 13, 2016 10:20 pm
Country: New Zealand
City: New plymouth
Year: 2016

Re: Horn Problem?

Post by DaveNZ » Mon Nov 21, 2016 6:16 am

Same here, no horn when the bikes hot. FFS how did this pass their quality control, another warranty claim along with the non existent quick shifter, and the broken spur on the stand.
2016 1290GT-remus link and muffler, 2010 Black 1200 Multistrada full Termi system with mapping, 2005 SMR 640, full Titanium system, Mikuni flatside racing carb, 2 sets of wheels, 18 litre tank, and a nice soft seat.

MikeR
125cc
125cc
Posts: 5
Joined: Mon Aug 22, 2016 5:07 pm
Country: United States
City: Lafayette
Year: 2015
Location: Lafayete, CO

Re: Horn Problem?

Post by MikeR » Mon Nov 21, 2016 1:57 pm

MR C wrote:Here is where I've put my stock horn, it's perfect now .

Image
I had the dealer move mine here as well. No more problems,

Plake
125cc
125cc
Posts: 12
Joined: Sun Oct 16, 2016 1:48 pm
Country: UK
City: Brighton
Year: 2016
Colour: Black

Re: Horn Problem?

Post by Plake » Sun Nov 27, 2016 10:27 pm

Sooooo....Dealer fitted the Denali Soundbomb, first time I had to use it in anger a "General Failure" message popped up in the screen which wouldn't go away.

Had a look under the seat. Lots and lots of cut wires wrapped in insulating tape but nothing obviously loose.

Took it back to the dealer who told me that the ECU is fried and needs replacing and that the cause was the Soundbomb which they say in fact cannot be fitted to the Superduke. They asked me to bring in my keys to recode. 1 week later got a call saying that they need to order a new ignition switch which has a 7-10 day lead time. Bike will be off the road for weeks because of this. Misery.

Post Reply