Horn Problem?

Tancakar
675cc
675cc
Posts: 283
Joined: Mon May 09, 2016 11:42 pm
Country: UK
City: London
Year: 2016

Horn Problem?

Post by Tancakar » Sun Jun 19, 2016 7:03 pm

There is problem with the horn as you might all know, but what i wonder if this is on all the bikes ? when the bike gets hot the horn doesnt work.
Is any of you sort this out yet ? what is the solution ? Seeing my dealer tomorrow i will let you know if know anything .

mrossk
500cc
500cc
Posts: 145
Joined: Tue Oct 27, 2015 1:46 am
Country: usa
City: santa fe
Year: 2015
Contact:

Re: Horn Problem?

Post by mrossk » Sun Jun 19, 2016 7:05 pm

I've got the same problem, let us know if you find out anything.

Tancakar
675cc
675cc
Posts: 283
Joined: Mon May 09, 2016 11:42 pm
Country: UK
City: London
Year: 2016

Re: Horn Problem?

Post by Tancakar » Tue Jun 21, 2016 3:53 pm

as usual the problem didn't seems to be there as soon as i got to the dealer. they said if it happens again they will definitely sort it out in the first service by changing my horn. I think they dont know the problem too. So they are reporting to KTM. MY bike was in the computer for checking any faults. the Quick shifter seems to work but not seamless.

mrossk
500cc
500cc
Posts: 145
Joined: Tue Oct 27, 2015 1:46 am
Country: usa
City: santa fe
Year: 2015
Contact:

Re: Horn Problem?

Post by mrossk » Tue Jun 21, 2016 4:02 pm

Thanks for the report- frustrating that there's no acknowledgement. For me, the oil temp has to show about 190F (@88C) before the horn quits.

Tancakar
675cc
675cc
Posts: 283
Joined: Mon May 09, 2016 11:42 pm
Country: UK
City: London
Year: 2016

Re: Horn Problem?

Post by Tancakar » Wed Jun 22, 2016 1:40 pm

The same here

Tancakar
675cc
675cc
Posts: 283
Joined: Mon May 09, 2016 11:42 pm
Country: UK
City: London
Year: 2016

Re: Horn Problem?

Post by Tancakar » Fri Jul 22, 2016 2:44 pm

Latest update to horn problem is go and see your dealers and tell them the problem, 2016 super duke R experience the same problem and change under warranty. i ordered mine !

Super Duke Antoine
125cc
125cc
Posts: 27
Joined: Wed Aug 24, 2016 8:45 pm
Country: The Netherlands
City: The Hague
Year: 2016
Colour: Black & Orange

Re: Horn Problem?

Post by Super Duke Antoine » Sat Sep 03, 2016 3:33 pm

Mine has the same problem. See: https://www.youtube.com/watch?v=HWVvkQkU9Hg.
First service will be Wednesday. No doubt that my dealer will fix this. Compared to my Honda VFR 1200 (new drive shaft) this is a walk in the park. :D

Super Duke Antoine
125cc
125cc
Posts: 27
Joined: Wed Aug 24, 2016 8:45 pm
Country: The Netherlands
City: The Hague
Year: 2016
Colour: Black & Orange

Re: Horn Problem?

Post by Super Duke Antoine » Thu Sep 22, 2016 7:41 pm

Well, dealer couldn't reproduce the problem. It now occurs at 95 C. and 9 out of 10 times this is when you're in busy traffic. So, I'll demonstrate it to the dealer next time I'm there. Downside: you probably get a new KTM horn and that apparently doesn't fix the problem. Besides that the horn is useless on a highway. You're better off hitting the throttle extra once or twice than using the horn.

MR C
675cc
675cc
Posts: 256
Joined: Fri May 06, 2016 7:28 am
Country: UK
City: Derbyshire
Year: 2016

Re: Horn Problem?

Post by MR C » Thu Sep 22, 2016 11:59 pm

I've just been to Spain on the GT some 3000 miles later and the only issue I had was the horn, however I'm happy to only have a defective horn, I'm going to buy a proper loud jobby and stick it elsewhere and not behind the rad.

Super Duke Antoine
125cc
125cc
Posts: 27
Joined: Wed Aug 24, 2016 8:45 pm
Country: The Netherlands
City: The Hague
Year: 2016
Colour: Black & Orange

Re: Horn Problem?

Post by Super Duke Antoine » Fri Sep 23, 2016 5:56 am

Totaly agree with you. Best bike I've ever owned. If you want to replace the horn, please check the subject Replace horn / warning engine light in the Technical Discussions section.

MR C
675cc
675cc
Posts: 256
Joined: Fri May 06, 2016 7:28 am
Country: UK
City: Derbyshire
Year: 2016

Horn Problem?

Post by MR C » Fri Sep 23, 2016 10:12 am

Super Duke Antoine wrote:Totaly agree with you. Best bike I've ever owned. If you want to replace the horn, please check the subject Replace horn / warning engine light in the Technical Discussions section.
Yep as the bike runs canbus, im going to have a play with some diodes and relays.

Agree totally after owning a DVT multi and a XR the GT is awesome, even the suspension has got much better after the additional miles so presume it needs some bedding in, from bumpy mountain cols to fast sweepers the suspension is sublime, When I'm on the gas i can even feel the semi active tighten everything up making the bike razor sharpe, its a very impressive bike, I only wish that the quickshifter gave a pop through the changes as per the BMW because it feels a little numb without some interactive popping, I got to try the heated grips on all settings and max is very toasty however handguards would make them much better. On a 3k trip i had to adjust the chain once just a couple of mm and lubing it with a rattle can meant my mate had to push the bike along whilst I spray the chain, i sure theres a better way, having a cast side stand meant i wasn't going to pivot the bike on it to get the wheel off the floor Incase it snapped.

It's deffo one if the best bikes ive had and ive tried all the latest crop.

Plake
125cc
125cc
Posts: 12
Joined: Sun Oct 16, 2016 1:48 pm
Country: UK
City: Brighton
Year: 2016
Colour: Black

Re: Horn Problem?

Post by Plake » Sun Oct 16, 2016 1:58 pm

Yep, horn dies above 92 degrees here. Just tried to fit the Soundbomb mini as per the other thread, unsuccessfully.

Anyone got a good solution please??

MR C
675cc
675cc
Posts: 256
Joined: Fri May 06, 2016 7:28 am
Country: UK
City: Derbyshire
Year: 2016

Re: Horn Problem?

Post by MR C » Sun Oct 16, 2016 5:12 pm

Ive moved my stock Horn, used the M6 threaded hole on the left side of the head.

Plake
125cc
125cc
Posts: 12
Joined: Sun Oct 16, 2016 1:48 pm
Country: UK
City: Brighton
Year: 2016
Colour: Black

Re: Horn Problem?

Post by Plake » Sun Oct 16, 2016 5:31 pm

MR C wrote:Ive moved my stock Horn, used the M6 threaded hole on the left side of the head.
Is that just a straight swap with same bolts etc? Any chance of a photo please?

MR C
675cc
675cc
Posts: 256
Joined: Fri May 06, 2016 7:28 am
Country: UK
City: Derbyshire
Year: 2016

Re: Horn Problem?

Post by MR C » Sun Oct 16, 2016 10:14 pm

Plake wrote:
MR C wrote:Ive moved my stock Horn, used the M6 threaded hole on the left side of the head.
Is that just a straight swap with same bolts etc? Any chance of a photo please?
You use the horn bracket but have to drill a 6mm hole in the bracket to fit and extend the 2 wires, it's straight forward I'll get you a picture tomorrow [THUMBS UP SIGN]

orangepetrolcrush88
125cc
125cc
Posts: 22
Joined: Wed Oct 12, 2016 1:42 am
Country: United States
City: Santa Fe
Year: 2010

Re: Horn Problem?

Post by orangepetrolcrush88 » Mon Oct 17, 2016 4:24 am

mrossk wrote:Thanks for the report- frustrating that there's no acknowledgement. For me, the oil temp has to show about 190F (@88C) before the horn quits.
Ugh, same here. I'm going to my dealer tomorrow.

MR C
675cc
675cc
Posts: 256
Joined: Fri May 06, 2016 7:28 am
Country: UK
City: Derbyshire
Year: 2016

Re: Horn Problem?

Post by MR C » Mon Oct 17, 2016 3:50 pm

Here is where I've put my stock horn, it's perfect now .

Image

Plake
125cc
125cc
Posts: 12
Joined: Sun Oct 16, 2016 1:48 pm
Country: UK
City: Brighton
Year: 2016
Colour: Black

Re: Horn Problem?

Post by Plake » Mon Oct 17, 2016 8:02 pm

MR C wrote:Here is where I've put my stock horn, it's perfect now .

Image
Cheers mate, neat job, well done.

After thinking about it I've decided to get the dealer to fit a denali soundbomb when I take it in for a suspension setup in a couple of weeks. Mental loudness :lol:

MR C
675cc
675cc
Posts: 256
Joined: Fri May 06, 2016 7:28 am
Country: UK
City: Derbyshire
Year: 2016

Re: Horn Problem?

Post by MR C » Mon Oct 17, 2016 10:21 pm

Where will you fit the Denali ! theres very little room .

Super Duke Antoine
125cc
125cc
Posts: 27
Joined: Wed Aug 24, 2016 8:45 pm
Country: The Netherlands
City: The Hague
Year: 2016
Colour: Black & Orange

Re: Horn Problem?

Post by Super Duke Antoine » Fri Oct 21, 2016 4:15 pm

My dealer reported it to KTM in the Netherlands. They said I was the first and send a new horn. Dealer replaced it within the warranty. Tested it and yes, it worked above an oil temperature of 95C.


Verzonden vanaf mijn iPhone met Tapatalk

Post Reply