how is your Quickshifter ?

Post Reply
Tancakar
675cc
675cc
Posts: 283
Joined: Mon May 09, 2016 11:42 pm
Country: UK
City: London
Year: 2016

how is your Quickshifter ?

Post by Tancakar » Thu Jun 16, 2016 7:40 pm

Hi all

now it has been 3 days since i have the bike mainly going two up nothing mad just shifting near 6000 rpm. mainly even not go that high 4k/5k seems nice to shift.
I have so many bikes with quickshifter at past, while you twist the throttle with out using the clutch or letting go the throttle i try to shift but its juggles not smooth all the bike feels like completely cut off and restart .

What is your experience ? i check the menu it says quickshifter is on but how do i know if its really on :)

besides i am seeing the dealer this week as my seat key is broken from delivery and my horn doesn't work. my paint seems to have lots of orange peel ? While i am there i will show them the quickshifter too.

Tell me what you think ?

User avatar
Yoozy
Supporter
Supporter
Posts: 954
Joined: Thu Oct 03, 2013 6:42 pm
Country: England
City: Extreme Mancunian.
Year: 2011
Colour: Black
Model: SMT

Re: how is your Quickshifter ?

Post by Yoozy » Thu Jun 16, 2016 10:00 pm

My q/s works perfectly. I've only been using the clutch to 2nd then the q/s and it works spot on as long as you are actually increasing the rev or holding a steady higher rpm. It's seamless tbh. Low rpm and in traffic I don't use it. But on the move always. My horn is erratic. Tomorrow I'm going to see if the new tank trim fits better than the one fitted.
A gut full of ale and a head full of magic.

Image

WWW.TUONOWORLD.COM

Tancakar
675cc
675cc
Posts: 283
Joined: Mon May 09, 2016 11:42 pm
Country: UK
City: London
Year: 2016

Re: how is your Quickshifter ?

Post by Tancakar » Fri Jun 17, 2016 12:45 pm

may be my quickshifer is not working. The gear lever to be honest is to awkward, the lever pedal bit its too small. there is update i saw in the forum i might do that.

User avatar
Yoozy
Supporter
Supporter
Posts: 954
Joined: Thu Oct 03, 2013 6:42 pm
Country: England
City: Extreme Mancunian.
Year: 2011
Colour: Black
Model: SMT

Re: how is your Quickshifter ?

Post by Yoozy » Fri Jun 17, 2016 2:27 pm

Tancakar wrote:may be my quickshifer is not working. The gear lever to be honest is to awkward, the lever pedal bit its too small. there is update i saw in the forum i might do that.

You can space them out, away from the arm and put a longer bolt in. I've done it with gear and brake. I've lowered me pegs and it still works perfectly. It only needs a gentle touch too, can't fault it.
A gut full of ale and a head full of magic.

Image

WWW.TUONOWORLD.COM

Tancakar
675cc
675cc
Posts: 283
Joined: Mon May 09, 2016 11:42 pm
Country: UK
City: London
Year: 2016

Re: how is your Quickshifter ?

Post by Tancakar » Fri Jun 17, 2016 9:57 pm

oh can you lower the pegs ? i didn't realize i just though about it :) i will do this mode ;)

User avatar
Yoozy
Supporter
Supporter
Posts: 954
Joined: Thu Oct 03, 2013 6:42 pm
Country: England
City: Extreme Mancunian.
Year: 2011
Colour: Black
Model: SMT

Re: how is your Quickshifter ?

Post by Yoozy » Sat Jun 18, 2016 8:41 am

These things http://www.ebay.co.uk/itm/321814282518? ... EBIDX%3AIT look top notch to me.

Image

I don't think I'll be doing any standing up on em though. It's a bit of a faff finding the stand as well but you get used to it.
A gut full of ale and a head full of magic.

Image

WWW.TUONOWORLD.COM

Tancakar
675cc
675cc
Posts: 283
Joined: Mon May 09, 2016 11:42 pm
Country: UK
City: London
Year: 2016

Re: how is your Quickshifter ?

Post by Tancakar » Sat Jun 18, 2016 9:10 am

oh i see what you mean. I am thinking of trying something rubbery :) to soak some vibrations

these seem nice 8-)

http://www.ebay.co.uk/itm/281997011687? ... EBIDX%3AIT

DaveNZ
675cc
675cc
Posts: 287
Joined: Thu Oct 13, 2016 10:20 pm
Country: New Zealand
City: New plymouth
Year: 2016

Re: how is your Quickshifter ?

Post by DaveNZ » Sat Oct 15, 2016 4:58 am

My quick shifter in the 700Ks i did, never worked, it was turned on on the electronics side, but holding throttle open, click of the gear, but NO, no movement in the gear leaver, i tried it in sport mode, and in sports suspension, but no, a brick wall, was then thinking, maybe after the first service, but thats hopeful. the quick shifter on my EX V4 worked seamlessly, i had high hopes.
2016 1290GT-remus link and muffler, 2010 Black 1200 Multistrada full Termi system with mapping, 2005 SMR 640, full Titanium system, Mikuni flatside racing carb, 2 sets of wheels, 18 litre tank, and a nice soft seat.

Post Reply