Blank instrument screen

Post Reply
vet57air
675cc
675cc
Posts: 224
Joined: Tue Jun 24, 2014 5:46 am
Country: Canada
City: Port Alberni
Year: 2019
Colour: White

Blank instrument screen

Post by vet57air » Thu Jul 23, 2020 1:12 am

I have a 2019 1290 GT that I bought at the end of last season. Presently about 2000Kms.
Went for a west coast ride today. Had coffee and when I went to start the bike I had no instruments, black screen. I turned it off then back on...nothing, just the indicating lights at the bottom. Bike started and ran fine and rode home this way. It was about a 300km trip so when I got back to town I filled up. When I turned the bike back on the screen was back on. Anyone have any experiences like this?

User avatar
Aussie Dave
990cc
990cc
Posts: 970
Joined: Sat Mar 04, 2017 7:30 am
Country: Australia
City: Brisbane
Year: 2017

Re: Blank instrument screen

Post by Aussie Dave » Fri Jul 24, 2020 12:43 am

G'day Vet57air,

I've read a couple of these blank-out events...... but not seen if anyone has yet reported back with a definite cause/solution.

One poster advised that it may be the bike not sensing the key but I'd expect the GT would not start if that was the case. The GT can still sense the key even with the fob battery removed. By holding the key over the sensor in front of the fuel filler cap - if the software has been enabled correctly..... but that's only what I've readas I don't have a key/fob on my 17 model.

Interesting your screen came good after a 300km ride... it might have recovered earlier with a on/off cycle check too....maybe check for any weak electrical connections and the battery terminals (plus the -ve lead junction under the tank - see pic), or pinched wiring around the steering head.

It's likely a software corruption issue and probably needs a re-load...... it could be a faulty dash (warranty). Damn shame no one has reported how they got on with their dash issue or if it just went away, but I've only read of a couple this has happened to.

Get it back to the dealership for a check over..... surely they have had some bikes returned to KTM by now and know what might cause a blank out?
Earth lead under tank mounts.jpg
Earth lead under tank mounts.jpg (52.34 KiB) Viewed 528 times
2017 1290GT 27,484km, 05 CBR1100XX 130k kms

Prev loves...Capo1200TP-014, CBR11xx-002, 2xFZR1000genisis-94, FJ1200-89, FJ1100-84, XS1100P, VF1000F-83, CX500, VF750S, KZ1000J1-81, KZ1000ST-79, CB750F2-77, CB360T-74, CB175.. started it all in 1974 ;)

vet57air
675cc
675cc
Posts: 224
Joined: Tue Jun 24, 2014 5:46 am
Country: Canada
City: Port Alberni
Year: 2019
Colour: White

Re: Blank instrument screen

Post by vet57air » Sun Jul 26, 2020 8:07 pm

So I called my KTM dealer about blank screen. They had seen it before and said bring it down and they will check if there is an software update for my dash. If not they said they would order new. As it turns out there was an update for my bike, which they loaded. I asked if any bikes had come back with a blank screen after they had an update and they answered "no".

Post Reply