Paired devices forgotten at each start

Post Reply
m3ikoviki
125cc
125cc
Posts: 7
Joined: Mon Apr 08, 2019 10:04 am
Country: Netherlands
City: Delft
Year: 2019
Colour: Black

Paired devices forgotten at each start

Post by m3ikoviki » Mon Apr 08, 2019 10:17 am

Hello guys, I'm new here and excited to join all of you.
Just bought a 2019 GT and I have a weird issue.

Whenever I pair any device (phone or communication device) to my moto, the pairing is lost as soon as I turn the bike off and on again. The list of paired devices is empty on the dash while my phone have the bike in the paired devices list.

The following have been done:
- already activated KTM My Ride on the bike
- bluetooth always on on both bike and phones
- tried both ktm my ride free and payed (navigation) apps
- tried multiple phones: Samsung S9, S7, A8 and iPhone 6s
- re-patched the bike with my ride system a couple of times
- the dealer replaced my dash with a brand new one

None of the listed above worked.
Anyone got similar issue?

User avatar
reciprocation23
125cc
125cc
Posts: 32
Joined: Fri Oct 20, 2017 3:49 am
Country: USA
City: newburgh
Year: 2010

Re: Paired devices forgotten at each start

Post by reciprocation23 » Mon Apr 08, 2019 11:44 am

I have a 16. Was thinking about the 19 but the lack of an analog gauge of any sort deterred me. Heard of a few people with similar issue though.

Sent from my SM-G935V using Tapatalk


jjscsix
675cc
675cc
Posts: 206
Joined: Mon Jan 01, 2018 4:41 pm
Country: USA
City: Houston
Year: 2017
Colour: Silver

Re: Paired devices forgotten at each start

Post by jjscsix » Mon Apr 08, 2019 11:45 am

There are so few 2019s out there that you will get very little feedback. But I look forward to learning about the new features such as this from folks like you who do have a 2019. You might try posting on the Adventure forum (I assume there is one) where there may be more folks with the feature.

Keep us posted please.
2017 KTM Superduke GT, 2017 Yamaha FJR1300, 2012 Ducati 1199 Panigale

User avatar
Aussie Dave
990cc
990cc
Posts: 863
Joined: Sat Mar 04, 2017 7:30 am
Country: Australia
City: Brisbane
Year: 2017

Re: Paired devices forgotten at each start

Post by Aussie Dave » Tue Apr 09, 2019 8:10 am

Hop on to the "KTM forum" and select the super duke section....... or do an intro - that will get to all users!

There's quite a number of 19 owners and a heap of technical types active on that site, so you might get an answer quick smart...... then come back and let us know ;)
Current delights...1290GT-2017, CBR1100XX-2005

Prev loves...Capo1200TP-014, CBR11xx-002, 2xFZR1000genisis-94, FJ1200-89, FJ1100-84, XS1100P, VF1000F-83, CX500, VF750S, KZ1000J1-81, KZ1000ST-79, CB750F2-77, CB360T-74, CB175.. started it all in 1974 ;)

m3ikoviki
125cc
125cc
Posts: 7
Joined: Mon Apr 08, 2019 10:04 am
Country: Netherlands
City: Delft
Year: 2019
Colour: Black

Re: Paired devices forgotten at each start

Post by m3ikoviki » Wed Apr 10, 2019 8:57 pm

Thanks guys, I'm gonna try your suggestions and will surely post about a solution here when I find one :)

rhofton1
50cc
50cc
Posts: 1
Joined: Wed May 01, 2019 7:20 pm
Country: United Kingdom
City: Oakham
Year: 2019
Colour: Black & Orange

Re: Paired devices forgotten at each start

Post by rhofton1 » Wed May 01, 2019 7:33 pm

Hi everyone, just replaced my RSV4F and 1290S with a '19 GT (one bike for everything i hope) and the same problem. My dealer says KTM UK are aware of it and apparently working on a fix (coding error i guess) but i've got to say it's not convincing to bring a model to market with an error that definitely didn't exist on my 2017 1290s and seemingly not voluntarily acknowledge the issue. I've had not comm's from KTM to confirm the issue or their plans to fix it. It doesn't detract from the actual physical ride but for those long tours i want the functionality i was sold!! Aside from that, great piece of kit though...

m3ikoviki
125cc
125cc
Posts: 7
Joined: Mon Apr 08, 2019 10:04 am
Country: Netherlands
City: Delft
Year: 2019
Colour: Black

Re: Paired devices forgotten at each start

Post by m3ikoviki » Wed May 01, 2019 9:58 pm

Thank you for sharing the news :)

DaveNZ
990cc
990cc
Posts: 606
Joined: Thu Oct 13, 2016 10:20 pm
Country: New Zealand
City: New plymouth
Year: 2016

Re: Paired devices forgotten at each start

Post by DaveNZ » Thu May 02, 2019 6:18 am

rhofton1 wrote:
Wed May 01, 2019 7:33 pm
Hi everyone, just replaced my RSV4F and 1290S with a '19 GT (one bike for everything i hope) and the same problem. My dealer says KTM UK are aware of it and apparently working on a fix (coding error i guess) but i've got to say it's not convincing to bring a model to market with an error that definitely didn't exist on my 2017 1290s and seemingly not voluntarily acknowledge the issue. I've had not comm's from KTM to confirm the issue or their plans to fix it. It doesn't detract from the actual physical ride but for those long tours i want the functionality i was sold!! Aside from that, great piece of kit though...
Wellcome aboard rhofton, i also have had a RSV4 Tuono and the SD1290R, and have now settled for the 1290GT and a 790. Great bikes. All my KTMs have been reliable to date----------touch wood.
2016 1290GT-remus link and muffler, 2010 Black 1200 Multistrada full Termi system with mapping, 2005 SMR 640, full Titanium system, Mikuni flatside racing carb, 2 sets of wheels, 18 litre tank, and a nice soft seat.

m3ikoviki
125cc
125cc
Posts: 7
Joined: Mon Apr 08, 2019 10:04 am
Country: Netherlands
City: Delft
Year: 2019
Colour: Black

Re: Paired devices forgotten at each start

Post by m3ikoviki » Wed Jul 17, 2019 6:19 am

I have an appointment with my dealer this morning to get the dash updated. Apparently, KTM is aware of the issue and might have rolled out a fix in the last system update. I'm gonna let you know the outcome.

m3ikoviki
125cc
125cc
Posts: 7
Joined: Mon Apr 08, 2019 10:04 am
Country: Netherlands
City: Delft
Year: 2019
Colour: Black

Re: Paired devices forgotten at each start

Post by m3ikoviki » Wed Jul 17, 2019 8:36 pm

So, I got the dash upgraded with the latest update and it solved the issue. Now my phone and intercom are kept in the bike memory and no need to redo the whole pairing ritual everytime I start my bike. Especially with the intercom, the media control for volume and next/prev track is very helpful for people who listen to music while riding.

Mozkito2008
50cc
50cc
Posts: 4
Joined: Sat Aug 03, 2019 4:47 pm
Country: South Africa
City: Durban
Year: 2019
Colour: Black

Re: Paired devices forgotten at each start

Post by Mozkito2008 » Sat Aug 03, 2019 4:58 pm

Thank you for the feedback. What phone do you use. I have a Samsung Note 9 and also spoke to my dealer and they say system is not Samsung friendly which I find very strange.

m3ikoviki
125cc
125cc
Posts: 7
Joined: Mon Apr 08, 2019 10:04 am
Country: Netherlands
City: Delft
Year: 2019
Colour: Black

Re: Paired devices forgotten at each start

Post by m3ikoviki » Sun Aug 04, 2019 5:53 pm

Hello, I have a Samsung S9 Duo. I tried with an iPhone 6s and a Samsung S7 edge. I had the same problem with all of them. It was all fixed after the last dashboard update.

Mozkito2008
50cc
50cc
Posts: 4
Joined: Sat Aug 03, 2019 4:47 pm
Country: South Africa
City: Durban
Year: 2019
Colour: Black

Re: Paired devices forgotten at each start

Post by Mozkito2008 » Wed Aug 07, 2019 7:45 pm

Thank you

Mozkito2008
50cc
50cc
Posts: 4
Joined: Sat Aug 03, 2019 4:47 pm
Country: South Africa
City: Durban
Year: 2019
Colour: Black

Re: Paired devices forgotten at each start

Post by Mozkito2008 » Wed Aug 07, 2019 7:45 pm

Thank you

Mozkito2008
50cc
50cc
Posts: 4
Joined: Sat Aug 03, 2019 4:47 pm
Country: South Africa
City: Durban
Year: 2019
Colour: Black

Re: Paired devices forgotten at each start

Post by Mozkito2008 » Sun Aug 18, 2019 2:02 pm

I got my 2019 software updated and now the phone connect automatically.

DaveNZ
990cc
990cc
Posts: 606
Joined: Thu Oct 13, 2016 10:20 pm
Country: New Zealand
City: New plymouth
Year: 2016

Re: Paired devices forgotten at each start

Post by DaveNZ » Sun Aug 18, 2019 9:11 pm

^ Cool, glad they got it sorted for you.
2016 1290GT-remus link and muffler, 2010 Black 1200 Multistrada full Termi system with mapping, 2005 SMR 640, full Titanium system, Mikuni flatside racing carb, 2 sets of wheels, 18 litre tank, and a nice soft seat.

Post Reply