Horn has stopped working.

Post Reply
MortenOJ
125cc
125cc
Posts: 13
Joined: Mon Sep 26, 2016 2:59 pm
Country: Denmark
City: Odense
Year: 2016
Colour: White

Horn has stopped working.

Post by MortenOJ » Thu Jun 15, 2017 5:06 pm

Hi guys. The horn on my 2017 Duke has suddently stopped working. Anyone with the same problem? Any suggestions for troubleshooting?

Freude am Fahren
500cc
500cc
Posts: 98
Joined: Mon Dec 12, 2016 10:41 pm
Country: USA
City: Miami
Year: 2016
Colour: Black & Orange

Re: Horn has stopped working.

Post by Freude am Fahren » Fri Jun 16, 2017 5:34 pm

Mine stopped working, looked down and the wire had just become disconnected (I think it was my fault while working on something else). Worth a quick check. If it's intermittent, it's probably not that.

I have hear of others having issues that required a new button pod though. This would be more likely if it happens once in a while (especially when hot, I've heard).

mrossk
500cc
500cc
Posts: 133
Joined: Tue Oct 27, 2015 1:46 am
Country: usa
City: santa fe
Year: 2015
Contact:

Re: Horn has stopped working.

Post by mrossk » Fri Jun 16, 2017 7:56 pm

I've a 2016 and the horn doesn't work when hot. I've read of others with the same issue. My bike is now out of warranty and haven't yet figured out a solution.

User avatar
5150 Pops
Supporter
Supporter
Posts: 262
Joined: Sun Jul 31, 2016 5:10 am
Country: USA
City: NORTH CHESTERFIELD
Year: 2015
Colour: Black
Location: USA Virginia

Re: Horn has stopped working.

Post by 5150 Pops » Sat Jun 17, 2017 12:44 am

MortenOJ wrote:Hi guys. The horn on my 2017 Duke has suddently stopped working. Anyone with the same problem? Any suggestions for troubleshooting?
Check the electrical connection is secure, and check fuses.
Otherwise, it's under warranty, take it back.

big tall dave
125cc
125cc
Posts: 26
Joined: Wed Feb 01, 2017 2:16 am
Country: USA
City: Nashville
Year: 2016

Re: Horn has stopped working.

Post by big tall dave » Tue Jun 20, 2017 5:22 pm

Mine stopped working every time it got really hot. Last October, my dealer replaced it under warranty and bent it back a bit so it was further away from the rad. No probs since.

jay-ninja
125cc
125cc
Posts: 10
Joined: Mon Aug 11, 2014 7:42 pm
Country: UK
City: Exeter
Year: 2014
Colour: White
Model: SMT

Re: Horn has stopped working.

Post by jay-ninja » Sun Jun 25, 2017 11:52 am

I have got the same problem on my 2011 KTM 990 SMT - Horn just stopped working checked fuses undersea and all seem good - Annoyingly my MOT is due next week !!

mogas64
500cc
500cc
Posts: 109
Joined: Mon Jun 05, 2017 5:45 pm
Country: England
City: Leamington Spa
Year: 2016
Model: SMT
Location: Warwickshire

Re: Horn has stopped working.

Post by mogas64 » Fri Jan 05, 2018 8:09 pm

My horn stops working when hot, like when riding in town traffic , once on the open road after a short while it works again, just a foible of the bike I guess!!.
Current bike, 2016 KTM 1290 Super Duke R SE with lots of spangly bits and a private plate Fnarr Fnarr !!!🇬🇧

Post Reply