Dash board failure

Here be mechanigeeks. Anything technical that is not a teething problem.
Post Reply
davi82a
50cc
50cc
Posts: 3
Joined: Thu Jun 22, 2017 8:08 am
Country: Scotland
City: Aberdeen
Year: 2008

Dash board failure

Post by davi82a » Thu Jun 22, 2017 8:23 am

Hello all,
Been having some problems with my 2008 990 SM. The tachometer and LCD display are both dead. The only light that appears to be working is the immobilizer. I had issues with the screen fogging up before hand. I took the whole unit apart wearing anti static tab and gloves to avoid damaging circuit board further. It was a bit dirty in places so I cleaned with electrical cleaner and cotton buds. Looks immaculate now, however, when I put it together again it remains non functional. I'm guessing its a component in the circuit that has gone i.e. resistor, diode. I'm wondering if anyone on here is clues up with the white mans magic and can point me in the right direction as to what component is to blame. Failing that, would be useful to have some links as to where I can buy a replacement (both factory fitted or aftermarket) Interested in an aftermarket replacement down to the fact the stock one is of poor quality. I'm not fussed, any useful information that'll give me an idea of how fast i'm going would be much appreciated.
Thanks,
Davie

User avatar
jhalfhide
675cc
675cc
Posts: 259
Joined: Sat Jun 25, 2016 3:39 pm
Country: United Kingdom
City: East Sussex
Year: 2013
Colour: Black & Orange
Contact:

Re: Dash board failure

Post by jhalfhide » Thu Jun 22, 2017 8:48 am

If all else fails, android tablet hooked up to TuneECU as a temporary measure


Sent from my iPhone using Tapatalk
Now: 2013 KTM 990 SMT
Old: 2010 Ducati Faultistrada 1200s (Broke)
Old: 2007 Yamaha R1 (Sold)
Old: 2009 KTM 990 SMR (Stolen)
Old: 2008 Ducati 848 (Written off... whilst parked :roll: )
Old: 2007 ZX6R (Written off... elderly driver)
Old: 1996 ZX6R (Sold)

Post Reply