HELP my bike is beeping

Here be mechanigeeks. Anything technical that is not a teething problem.
Post Reply
Elvis
250cc
250cc
Posts: 68
Joined: Fri Aug 14, 2015 10:15 am
Country: Germany
City: Dresden
Year: 2012

HELP my bike is beeping

Post by Elvis » Fri Jul 06, 2018 6:47 pm

So i done the following:
* cooling hose replacement due to small crack and leak
* spark plugs
* replace the ITG with DNA stage 3
* put back the secobdary plates

after the above i am getting beeping sound at 2000-3000 rpm that can be heard when riding very clear
this is super annoying, the bike runs well with no issues
any ideas?

https://www.youtube.com/watch?v=DRdKB8wxPKM

User avatar
jhalfhide
675cc
675cc
Posts: 287
Joined: Sat Jun 25, 2016 3:39 pm
Country: United Kingdom
City: East Sussex
Year: 2013
Colour: Black & Orange
Contact:

Re: HELP my bike is beeping

Post by jhalfhide » Fri Jul 06, 2018 7:26 pm

You’re right, that’d drive me mental. Sounds like a Girl Scouts whistle rather than a snarling beast.

I think you’ve got an air leak somewhere. Double check your air box fitment, check the rubbers around the throttle bodies too.


Sent from my iPhone using Tapatalk
Now: 2013 KTM 990 SMT
Old: 2010 Ducati Faultistrada 1200s (Broke)
Old: 2007 Yamaha R1 (Sold)
Old: 2009 KTM 990 SMR (Stolen)
Old: 2008 Ducati 848 (Written off... whilst parked :roll: )
Old: 2007 ZX6R (Written off... elderly driver)
Old: 1996 ZX6R (Sold)

Elvis
250cc
250cc
Posts: 68
Joined: Fri Aug 14, 2015 10:15 am
Country: Germany
City: Dresden
Year: 2012

Re: HELP my bike is beeping

Post by Elvis » Sat Jul 07, 2018 3:32 pm

After you pointed out it is an air leak i loaded a map with seconderies fully open all the time and now i get no noise.

Based on the above i have a leak below the secondary valve or somehow i installed the scondary in the wrong way (if that is even possible).

I can not see any leak on the throttle bobdy

User avatar
jhalfhide
675cc
675cc
Posts: 287
Joined: Sat Jun 25, 2016 3:39 pm
Country: United Kingdom
City: East Sussex
Year: 2013
Colour: Black & Orange
Contact:

Re: HELP my bike is beeping

Post by jhalfhide » Sat Jul 07, 2018 4:39 pm

So what openings did the map have before. Maybe your flies were barely open, creating the whistling (big air, tiny gap). If opening the flies has cured it, I’d either leave them as they are or go back to the old map but increase the openings at that rpm range by 10%


Sent from my iPhone using Tapatalk
Now: 2013 KTM 990 SMT
Old: 2010 Ducati Faultistrada 1200s (Broke)
Old: 2007 Yamaha R1 (Sold)
Old: 2009 KTM 990 SMR (Stolen)
Old: 2008 Ducati 848 (Written off... whilst parked :roll: )
Old: 2007 ZX6R (Written off... elderly driver)
Old: 1996 ZX6R (Sold)

Elvis
250cc
250cc
Posts: 68
Joined: Fri Aug 14, 2015 10:15 am
Country: Germany
City: Dresden
Year: 2012

Re: HELP my bike is beeping

Post by Elvis » Sat Jul 07, 2018 11:08 pm

I use the Kev performance map for stock bike plus 2% richer on the all range.
In this map the secondary is 0% at small opening of throttle and low rev (untill 3000 rpm)
I think this is factory settings.
Today before i went for a ride i changed all the zero in the map to 10% and no noise although by now i became paranoid and could its still there but not so nooisy.

User avatar
limeyduffa
900cc
900cc
Posts: 345
Joined: Tue Mar 15, 2011 9:22 am
Country: Australia
City: Adelaide
Year: 2012
Colour: Black
Model: SMT

Re: HELP my bike is beeping

Post by limeyduffa » Sun Jul 08, 2018 4:12 am

If there was a leak in the rubber sleeve, you would expect the engine to be revving high ?

When you fitted the rubber sleeve and throttle body, did you lub the rubber sleeve ?

Try causing the whistling again, but put your hand partially over each throttle opening as the engine is whistling to see if that makes the whistle better or worse. This should indicate what throttle is at fault.

Elvis
250cc
250cc
Posts: 68
Joined: Fri Aug 14, 2015 10:15 am
Country: Germany
City: Dresden
Year: 2012

Re: HELP my bike is beeping

Post by Elvis » Tue Jul 10, 2018 7:34 pm

i actually removed the throttle bodies a year a go when i installed the ITG so now when i installed the DNA there was no need to touch them but yes i clean and moister every rubber part i re-install on the bike.

I will put back the original map and try to spry WD40 below the filter box to see if beeping noise will change pitch

Post Reply